Условие в Excel. До 3 лет - 5%, 3-5 лет - 10%

Товарищи шарящие, помогите чайнику.
Нужно написать условие До 3 лет-5%, 3-5 лет-10%, 6-10 лет-15%, свыше 10 лет-20%
В виде функции для excel

Похоже что Вам нужна (функция СЧЁТЕСЛИ)

Function TheromanovIF(rng As Range)
    Dim myValue As Double
    TheromanovIF = 0
    If IsNumeric(rng.Value) Then
        myValue = CDbl(rng.Value)
        If myValue <= 3 Then
            TheromanovIF = 3
        ElseIf myValue <= 5 Then
            TheromanovIF = 10
        ElseIf myValue <= 10 Then
            TheromanovIF = 15
        Else
            TheromanovIF = 20
        End If
    Else
        TheromanovIF = "Input Data Error"
    End If
End Function

формулой то как-то так:

=ЕСЛИ(A1<4;3;ЕСЛИ(A1<6;10;ЕСЛИ(A1<11;15;20)))
1 Симпатия

В конечном счете выяснится, что у ТС в каждой строке таблицы есть две даты и нужно вычислить сколько лет между ними и взять определенный процент от некой суммы в этой же строке )

Этого мы уже не узнаем, ведь, скорее всего, он такую тему создал на многих форумах. Уже получил ответ и мы его больше увидим.

А ответ пускай будет для поисковиков :wink:

2 Симпатий

Все в порядке, спасибо за помощь)